Discussion:
MacVim wierdness.
Add Reply
Bill Hill
2018-12-03 14:35:43 UTC
Reply
Permalink
Hi, I've installed MacVim, which worked fine, but since it doesn't have python enabled some of the extras I use (YouCompleteMe, ConqueGDB) don't work.
So I installed: sudo port install MacVim +cscope+huge+python37+ruby25
I've got links in /usr/local/bin such as: "lrwxr-xr-x 1 bill staff 51 May 3 14:18 /usr/local/bin/gvim -> /Applications/MacPorts/MacVim.app/Contents/bin/gvim"
I've been using MacVim like that for ages and everything seems fine. Then I tried to click the app icon, /Applications/MacPorts/MacVim.app
This pops up an error message: "You have macOS 10.13.6. The application requires macOS 10.14 or later."
Yep, still works fine from the command line! And I've tried the default variant, too and that *will* launch from the app icon.
--
Red to red, black to black, switch it on, but stand well back.
Ryan Schmidt
2018-12-05 08:24:40 UTC
Reply
Permalink
Post by Bill Hill
Hi, I've installed MacVim, which worked fine, but since it doesn't have python enabled some of the extras I use (YouCompleteMe, ConqueGDB) don't work.
So I installed: sudo port install MacVim +cscope+huge+python37+ruby25
I've got links in /usr/local/bin such as: "lrwxr-xr-x 1 bill staff 51 May 3 14:18 /usr/local/bin/gvim -> /Applications/MacPorts/MacVim.app/Contents/bin/gvim"
I've been using MacVim like that for ages and everything seems fine. Then I tried to click the app icon, /Applications/MacPorts/MacVim.app
This pops up an error message: "You have macOS 10.13.6. The application requires macOS 10.14 or later."
I installed MacVim with those variants on my High Sierra system, and I didn't see that problem.

Is it possible that you double-clicked the wrong app icon, or that you have another copy of MacVim.app on your system and that's the one that you launched?

Does the problem persist after you log out of macOS and log back in (or restart)?
Post by Bill Hill
Yep, still works fine from the command line! And I've tried the default variant, too and that *will* launch from the app icon.
Loading...